Performance Test Failed in Marathon VCL card

  • I have installed a Marathon VCL frame grabber with the runtime v5.6.1 and flashed my applet there. When I tried to do performance test in Micro diagnostics , I received an error attached here. Could anyone help on this?.

    forum.silicon.software/index.php?attachment/423/

    Please contact your local support center for issues like this.


    Basler Support contact list...


    From my point of view the not running perfromance test is not a real/hard issue as long as the hardware itself is present in microDiagnosis and microDisplay.

    It can be related to different version of applet in graber and existing file in runtime.

    Please let me know if our support could help you.


    Thank you.

    Björn RuddeMicroSiSo.png
    Field Application Engineer

  • Hi Jayasuriya


    are you trying to test a VisualApplets HAP file? *.hap? I think only AcquistionApplets can be tested in microDiagnostics.

    Unfortunately your attachment failed.


    Johannes

    Johannes Trein
    Teamleader Applications and Development
    SiliconSoftware GmbH
    siso-logo-animation2_2.gif



  • Dear Jayasuriya S.,


    Please check the DMA for the VA Design manually in microDisplay.

    So you have to build a CreateBlankImage approach instead of a camera into the design.

    Using SourceSelector would enable you to include the camera and the simulator at the same time.


    The CreateBlankImage operator would deliver as much data as the DMA can transfer.

    In microDisplay(X) you can see the obtained bandwidth and use this as a good indicator for the possible DMA performance.

    In case of further questions on this do not hesitate to contact me.

    Björn RuddeMicroSiSo.png
    Field Application Engineer